Extra wheel causing Maya fatal errors

Got questions, comments and/or feedback regarding Craft Director Studio? Post them here.
Post Reply
Makkster
Posts: 14
Joined: Wed Sep 29, 2010 1:31 pm

Extra wheel causing Maya fatal errors

Post by Makkster » Wed Sep 29, 2010 7:07 pm

I'm using Maya 2008 and Craft Studio 9.6.

I'm currently learning how to rig a tank model. Having successfully rigged the Crawler EXT to the main body and drive wheels, a firepower node to the gun and an observer cam to make the turret work.

Next I'm attempting to get the extra wheels to work. At this point I'm experiencing fatal errors with Maya when I attempt to record. Any suggestions on what the cause would be?

I've only attempted to add 1 extra wheel thus far. I followed the web help advice and constrained the extra wheel suspension to the craft mesh for the crawler body and then constrained the high poly wheel to the extra wheel mesh.

When I attempt to record this after numerous attempts I either get a maya crash or the extra wheel does nothing.

Makkster
Posts: 14
Joined: Wed Sep 29, 2010 1:31 pm

Re: Extra wheel causing Maya fatal errors

Post by Makkster » Wed Sep 29, 2010 11:18 pm

I've now learnt that the problem is likely to be the way in which I attached the wheels. I like to use parent constraints and from another thread on this forum it seems that this will cause Maya to crash when you record. I'll give straightforward parenting a try and see if that resolves the issue.

User avatar
Micael Belin
CTO
Posts: 168
Joined: Thu Apr 03, 2008 9:39 am
Location: Gothenburg, Sweden
Contact:

Re: Extra wheel causing Maya fatal errors

Post by Micael Belin » Thu Sep 30, 2010 8:49 am

You are quite correct you should use simple parenting instead of parent constraint. Let me know if you still experience problems and we'll look into it
micael.fredriksson@craftanimations.com
http://www.craftanimations.com

Makkster
Posts: 14
Joined: Wed Sep 29, 2010 1:31 pm

Re: Extra wheel causing Maya fatal errors

Post by Makkster » Thu Sep 30, 2010 9:38 am

Thanks Micael.

I've got it working now - using parenting was the answer.

User avatar
Micael Belin
CTO
Posts: 168
Joined: Thu Apr 03, 2008 9:39 am
Location: Gothenburg, Sweden
Contact:

Re: Extra wheel causing Maya fatal errors

Post by Micael Belin » Thu Sep 30, 2010 10:10 am

Good to hear it worked out.

Is it possible for me to get a copy of the scene you had earlier for study? Even though we don't support parenting constraints,it still shouldn't crash like that and i would like to take a look at it.

Let me know if this is possible and i'll PM you the information to upload the scene to us.
micael.fredriksson@craftanimations.com
http://www.craftanimations.com

Makkster
Posts: 14
Joined: Wed Sep 29, 2010 1:31 pm

Re: Extra wheel causing Maya fatal errors

Post by Makkster » Thu Sep 30, 2010 11:37 am

Yes that would be great. I have since re set up the scene so I'm no longer using any constraints anywhere. I've also found that I couldn't get cogs to work so I used extra wheels in place of the cogs and scaled them up til they touched the floor. I'm onto the next step of creating treads now so if I leave that information in the scene perhaps you could take a look at this as well?

I've found that the treads are really killing my performance so it's very difficult to achieve anything. Also looking through the documentation it's not very clear to me.

I've created a tread but I'm not clear on how I attach a high poly track to the craft treads?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests