Custom surface for cars?

Got questions, comments and/or feedback regarding Craft Director Studio? Post them here.
Post Reply
dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Custom surface for cars?

Post by dv2000 » Mon Aug 13, 2018 9:48 pm

Hi I looked everywhere and could not find it. How do I add a custom terrain for a car?
Does this program support animated terrain surfaces? Like car drives on top of a moving train? Thanks

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Mon Aug 13, 2018 10:00 pm

Hi dv2000,

If you create a editable mesh surface and make the gravity direction mesh a child of the surface it will follow it. You can animate a 4-Wheeler Extended (not 4-Wheeler Free) on an animated terrain. Just make sure to uncheck "Use Fast Ray Cast" under Ray Cast Parameters in the 4-Wheeler Extended configuration.

You can see a tutorial in the manual, step 9
http://docs.craftanimations.com/tools/v ... ended.html

Ray Cast Parameters:
http://docs.craftanimations.com/tools/v ... Parameters
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 12:03 am

thanks. But for some reason car falls through. I have two surfaces linked to the gravity node. One is a moving platform but car goes through it I attached the scene through we transfer https://we.tl/0R1i8aMkDv
even using one surface and animating it up like a platform car stay and not goes up with the surface.

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 12:19 am

Also right click and delete 4car ext after it was simulated crashes 3ds max 2018.4

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Tue Aug 14, 2018 12:25 am

dv2000 wrote:
Tue Aug 14, 2018 12:19 am
Also right click and delete 4car ext after it was simulated crashes 3ds max 2018.4
Yes, this is a know issue that we are currently working on getting fixed as soon as we can.
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 12:32 am

thanks what about the animated surface, Do you know what should i do for it to work. Car still thinks it is a stationary surface.

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 4:48 am

i enabled use dynamic meshes and added noise to the ground and it works. The car follows the noise displacement.

The problem is what if I want my car to drive up onto the platform that starts moving up or over a bridge that opens up it seems that the car falls through because the platform was animated with regular animation keys. Is there solution for this?

Thank you

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 5:08 am

Another update:
after I click use dynamic meshes and then hit close and go back to the main preferences the box is unchecked again. For some reason it is not saving this option
maybe thats why I cannot drive on animated surfaces?

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 6:02 pm

Patrik Martin wrote:
Tue Aug 14, 2018 12:25 am
dv2000 wrote:
Tue Aug 14, 2018 12:19 am
Also right click and delete 4car ext after it was simulated crashes 3ds max 2018.4
Yes, this is a know issue that we are currently working on getting fixed as soon as we can.
Hi Patrick,
could you at least tell me if it is a bug with an animated surface so I dont have to continue trying to find the way to animate or I am doing something wrong? Thank you

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Tue Aug 14, 2018 8:41 pm

dv2000 wrote:
Tue Aug 14, 2018 6:02 pm
Hi Patrick,
could you at least tell me if it is a bug with an animated surface so I dont have to continue trying to find the way to animate or I am doing something wrong? Thank you
No this is a general issue in 3ds Max 2018. Not any of the other versions. This issue appears after creating animations and then deleting the tool.
dv2000 wrote:
Tue Aug 14, 2018 12:03 am
thanks. But for some reason car falls through. I have two surfaces linked to the gravity node. One is a moving platform but car goes through it I attached the scene through we transfer https://we.tl/0R1i8aMkDv
even using one surface and animating it up like a platform car stay and not goes up with the surface.
You should only have one surface (one polygon) not two in order for it to work properly.
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 14, 2018 9:43 pm

Patrik Martin wrote:
Tue Aug 14, 2018 8:41 pm
No this is a general issue in 3ds Max 2018. Not any of the other versions. This issue appears after creating animations and then deleting the tool.
dv2000 wrote:
Tue Aug 14, 2018 12:03 am
thanks. But for some reason car falls through. I have two surfaces linked to the gravity node. One is a moving platform but car goes through it I attached the scene through we transfer https://we.tl/0R1i8aMkDv
even using one surface and animating it up like a platform car stay and not goes up with the surface.
You should only have one surface (one polygon) not two in order for it to work properly.
Thanks! I am hoping you can fix it because we are planning to do an animation of a car going up the elevator or driving around a moving liner, for instance.

By the way I tried with one surface with release version 16 in 3ds max 2017 and animated terrain going up and down, forward and backwards and the car still did not go up or down almost like the terrain was treated as stationary . Also DYNAMIC MESHES always unchecks on its own in any version.

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Wed Aug 15, 2018 10:59 pm

dv2000 wrote:
Tue Aug 14, 2018 6:02 pm
You should only have one surface (one polygon) not two in order for it to work properly.

Hi Patrick,
maybe you know about this bug but after simulating helicopter, then playing back the animation and then closing 3ds max. 3ds max will crash

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Fri Aug 17, 2018 2:36 pm

dv2000 wrote:
Wed Aug 15, 2018 10:59 pm
Hi Patrick,
maybe you know about this bug but after simulating helicopter, then playing back the animation and then closing 3ds max. 3ds max will crash
What 3d program are you using. I tried it in 3ds Max 2018 and were not able to get the same crash. And just to double check on the flow:
1. Start 3d program
2. Open CDS and create a Helicopter
3. Set up the input settings for the helicopter
4. Record an animation of the Helicopter and hit stop Recording
5. Pull back the timeline and play the animation.
6. Hit pause at end of animation
7. Close 3d program
8. Crash?
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Fri Aug 17, 2018 2:56 pm

dv2000 wrote:
Tue Aug 14, 2018 9:43 pm
By the way I tried with one surface with release version 16 in 3ds max 2017 and animated terrain going up and down, forward and backwards and the car still did not go up or down almost like the terrain was treated as stationary . Also DYNAMIC MESHES always unchecks on its own in any version.
You do not need to check "Use Dynamic meshes" to be able to run on an animated surface.
I made a animation to show how I have done it https://youtu.be/hFwqmPkWCcc.
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Fri Aug 17, 2018 7:17 pm

Patrik Martin wrote:
Fri Aug 17, 2018 2:56 pm
dv2000 wrote:
Tue Aug 14, 2018 9:43 pm
By the way I tried with one surface with release version 16 in 3ds max 2017 and animated terrain going up and down, forward and backwards and the car still did not go up or down almost like the terrain was treated as stationary . Also DYNAMIC MESHES always unchecks on its own in any version.
You do not need to check "Use Dynamic meshes" to be able to run on an animated surface.
I made a animation to show how I have done it https://youtu.be/hFwqmPkWCcc.
HI Patrick
I did the same what you did and it is still not working. car just stays and the platform goes up without it. I animated vertices. I am using 2018 plugin version

here is my scene https://we.tl/t-70D104jx1l

Patrik Martin
Partner
Posts: 253
Joined: Mon Feb 25, 2008 1:07 pm
Location: Gothenburg, Sweden
Contact:

Re: Custom surface for cars?

Post by Patrik Martin » Mon Aug 20, 2018 5:03 pm

dv2000 wrote:
Fri Aug 17, 2018 7:17 pm
HI Patrick
I did the same what you did and it is still not working. car just stays and the platform goes up without it. I animated vertices. I am using 2018 plugin version

here is my scene https://we.tl/t-70D104jx1l
Ok so I know what is different between our scenes. It seems like you had used the "editable polygon" and I used the "editable mesh". When I change your plane to be an "editable mesh" it seems to work just fine, odd. I will discuss internally to see why this might be.
Partner
http://www.craftanimations.com
patrik.martin-at-craftanimations.com

dv2000
Posts: 28
Joined: Mon Aug 13, 2018 8:09 pm

Re: Custom surface for cars?

Post by dv2000 » Tue Aug 21, 2018 1:56 am

Patrik Martin wrote:
Mon Aug 20, 2018 5:03 pm
dv2000 wrote:
Fri Aug 17, 2018 7:17 pm
HI Patrick
I did the same what you did and it is still not working. car just stays and the platform goes up without it. I animated vertices. I am using 2018 plugin version

here is my scene https://we.tl/t-70D104jx1l
Ok so I know what is different between our scenes. It seems like you had used the "editable polygon" and I used the "editable mesh". When I change your plane to be an "editable mesh" it seems to work just fine, odd. I will discuss internally to see why this might be.
Thank you! It works great!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests